Couldn't run hashlink hello world (opengl error)

Hi there. I was trying to run the hello world with hashlink, but I’m getting an error related to OpenGL:

The application was unable to create an OpenGL context for you ATI Radeon 4800 Series video card. OpenGL 3.2+ is required, please update your driver.

According to OpenGL Extensions Viewer my graphics card supports OpenGL 3.3 (it’s, specifically, a Radeon HD 4870, with 1GB memory). I wish I could update my driver too, but the last update AMD released was back in 2013…

Would there be anything I could do?

(In case it matters, I’m on Windows 7.)