Problem compiling Hide (on mac)


#1

Hi there,

I successfully installed and tested Haxe4, Heaps, Hashlink and CastleDB on OSX. These are really great!

Then I would like to try Hide, as an authoring / previewing ide for heaps.

But I am not able to compile it on my mac. I get the error: Type not found: js,lib.Error at the second line of the fragment

#if haxe4
import js.lib.Error;
#else
import js.Error;
#end

Any help is highly appreciated since I am really stuck here…

Thank you for the incredible work with haxe / heaps, really like it!

Ciao!


#2

This code snippet is not compatible with Haxe 4-rc.2, you’d need a nightly build newer than that (or you could modify the sources to use js.Error in the haxe4 branch as well, but that would make updating a pain).


#3

Thanks!

If I force js.Error also for Haxe 4.rc.2 then the compiler stops in Buffer.hx (always in hxnodejs) in a similar haxe4 branch, this time related to js.lib.Object.

So I have to wait for a new built of hxnodejs? Are you suggesting this? (My apologize for asking…)


#4

Well, same thing there, you’d also need to replace that with js.Object.

Or get a nightly build of Haxe as mentioned, together with hxnodejs from GitHub.


#5

@Gama11. I followed your advices:

  1. downloaded haxe_latest (for mac) from the link you provided
  2. extracted it
  3. setup haxelib
  4. installed heaps: haxelib git heaps https://github.com/HeapsIO/heaps
  5. tested heaps (js and hl): fine
  6. downloaded hide from github
  7. compiled hide, it asked me for various libs: hxnodejs, hxbit, hscript, castle, hx3compt, domkit.
  8. installed all these libs with install git, all but castle (I was not able to find it in github)
  9. compiled again hide and…

same error “Type not found: js.lib.Error” in the same fragment of code:

#if haxe4
import js.lib.Error;
#else
import js.Error;
#end

What am I doing wrong???

Thanks so much!


#6

Are you sure it’s actually using the Haxe you downloaded? It sounds like it’s still using the old one, or at least an old standard library.


#7

I think it is using the new one: indeed it asked me to reinstall all those libs while I already had those in the old haxe. However is there a way to check this explicitly?

EDIT. You are right!
If I type: haxe --version in the VSC terminal I get the old one!

How is it possible?


#8

I see the old haxe also in the HAXE DEPENDENCIES of VSC. How can I instruct VSC to use the new Haxe?


#9

By default it just uses what’s in your PATH. You could set the haxe.executable setting to something else though.


#10

Thanks! I was able to reinstall the latest haxe4 build. I see that the hide compilation process takes longer… before stopping with the following errors:

There are some warning in haxe but all the errors are in hide, and they are all about “Script”.

Again, I am not an expert here… so please could you help?


#11

Sounds like CastleDB might not be up to date? Try installing it from https://github.com/ncannasse/castle.


#12

Thank you so much! I reinstalled castleDB and the compilation process now runs smoothly…

I downloaded and installed also nwjs and I am now able to test Hide, finally!

(Some errors happens when I run Hide but nothing seems serious and the editor is usable…)

Thanks again!