Problem with HashLink (overflow)


#1

Hi, i hope you are good :), i have a problem with HashLink, i followed all instructions, step by step, i compile successfuly on visual studio, download all the dependencies, but i have this error

and this is the code in the launch file

{
“version”: “0.2.0”,
“configurations”: [
{
“name”: “HashLink”,
“request”: “launch”,
“type”: “hl”,
“hxml”: “compile.hxml”,
“cwd”: “${workspaceRoot}”,
“preLaunchTask”: {
“type” : “haxe”,
“args” : “active configuration”
}
}
]
}

it’s pretty weird because i made the same thing in other pc and it worked, but not in my pc, and it has better specs :/.

What could be the problem?? i reinstalled all (visual studio code included) but doesn’t work :/.

I hope you can help me :), and thanks!!


#2

Check your VSCode version, HashLink debugger version, Haxe version and HashLink version.


#3

All is the latest version because i reinstalled all :/, visual studio system version, haxe 4 preview 5, hashlink compatible with that preview and the debugger that came with haxe pack tools. But i will check again the vs tools


#4

Ok, i tried all, reinstalled all again, i have hashlink 1.8.0, haxe 4.0.0-preview 5, hashlink debugger 0.5.0, VS code 1.29 (latest version), tried 32bit and 64bit, tried VS code 1.28 version too… uninstalled antivirus, prayed to greek gods

And nothing work :confused: (using js works but not hl), i really don´t know what´s wrong, how i said it before, i did the same thing in other pc and worked first try…