helloHeaps wont compile due to "Printer"

I am trying to do the helloHeaps example, I cannot get it to compile

I tried updating things with haxelib update
I tried the launch.json things with the chrome debugger extension
I keep getting errors about printer.hx and BatchShader.hx

I don’t know if it matters but I dont have hashlink installed, I cant get it to work for some reason so I am trying to use neko, which I know works from other projects

Here is the command I am using
haxe compile.hxml

It prints out this
Haxe Compiler 4.2.0 - ©2005-2020 Haxe Foundation
Usage: haxe [options] [hxml files and dot paths…]
and then the help stuff
and then these errors
/home/user/haxelib/heaps/1,8,0/hxsl/Printer.hx:234: characters 16-18 : Unmatched patterns: OpSpread
/home/user/haxelib/heaps/1,8,0/hxsl/Printer.hx:234: characters 16-18 : … For function argument ‘v’
/home/user/haxelib/heaps/1,8,0/hxsl/BatchShader.hx:3: character 1 : Build failure

Is there anything that I am missing?

For now you might need switch back to Haxe 4.1.x as version 4.2 is not working for Heaps at the moment. And use the Heaps git version by haxelib git heaps https://github.com/HeapsIO/heaps.git so don’t use “heaps 1.8.0”. I hope it will solve some of the trouble … (You can also ask us on discord if you haven’t already)

edit:
Latest Haxe version then would be Haxe 4.1.5
(and there’s nothing you’re “missing” at the moment it isn’t really mentioned on the official pages for now… you get the open source feelin’ :wink: )

1 Like