How to install Heaps on my MacMini M1 Big Sur?

Hi, i’m trying to install heaps Engine but without success…The steps are very confusing!!Can you make a final installer??More simple?? Haxe i have succeded, because there a beauty installer and works great!!!But i can’t install HashLink…Very difficult for Mac os x…
Very confusing also Visual studio Code…Can somebody Help me …step by step…Please??..Best regard, Lestroso.

Run cmd “brew install hashlink”

Did you get it running @fasasoftware? Any other problems so far? Have been thinking to update my laptop to M1 as well and therefore this is interesting topic.

Excellent “step by step” instructions :slight_smile:.

@ksurakka I was able to build hashlink from source with some changes back in June, you can see those here. Credit goes to the original posters on reddit.

Out of curiosity, I ran “brew install hashlink” today and received an error “no bottle available!”.

Hello! I am also wondering if there is any way to install HashLink on my M1. I tried using the repository that @greg suggested, but I got tons of errors all along the lines of

libs/ssl/ssl.c:412:23: error: no member named 'len' in 'struct mbedtls_asn1_buf'

(there were tons more in different places and in different structs, but all in the same file)

I have tried a bunch of different solutions, including trying to build from source, which tells me that
unknown FP unit 'sse' when I try to build without changing anything.

The only thing that I can think of that might work is to install brew using the intel prefix (/usr/local) and dealing with that whole shebang to get x86_64 libraries installed so that I can build it for x86_64.

If anyone knows how to compile this natively for arm64 please let me know!


I managed to install the x86_64 version of hashlink by running the terminal through rosetta, installing the x86_64 version of homebrew, and using that version to install the dependencies for hashlink. Building threw a few non-fatal warnings but it compiled and installed fine, and now I can use it in both rosetta and non-rosetta terminals (though it will always run hashlink through rosetta 2). If anyone wants more information on how to do it, please let me know and I can get on IRC or something to help you out.

Was wondering if there was an update on that front. I installed using brew install haxe hashlink, haxelib setup, and haxelib install heaps hlopenal hlsdl. I followed the Hello Hashlink guidelines, but I can’t get the project to build on my M1 like it does on Windows.

The biggest issue for me was making HL work on the mac (with an M1 processor). Unfortunately, brew install hashlink doesn’t just work out of the box, because you need to compile using the Intel architecture, otherwise you’ll get a seg fault when trying to run a simple Hello World example.

I managed to do it, see this for full steps:

You’re welcome :smiley: